react-native에 storybook 5.x를 쓰고 싶다면...


(이종은(Jong Lee)) #1

:warning: storybook 5.1 이 되면서 react-native 관련 베타딱지가 없어졌습니다. 이제는 기본 문서에 나와있는 방법으로 정상 작동하는 것 같네요 :slight_smile:


요즘 저는 기획자에게 리액트 네이티브를 알려주고 있는데요. 이렇게 아직 익숙하지않은 분들에게는 UI작업할 때 Storybook을 이용하면 많이 편리할 것 같아서 설정해주었습니다. (사실 익숙여부를 떠나서 Stroybook 써보시길 추천합니다.)

그런데 최근 Storybook 5.x에서는 react-native 가 alpha 단계라서 설정이 잘 안되서 애먹었네요. 제가 나중에 까먹을까봐 또한 비슷한 삽질을 하실 분들을 위해 남겨둡니다.

공식문서의 가이드대로 설치하지 마시고 다음과 같이 설치합니다.

npx -p @storybook/[email protected] sb init

package.json에 추가된 스크립트 중엔 storybook 부분의 포트를 6006에서 7007로 바꿔줍니다.
npm run storybook 실행할 때 babel-loader 관련 에러가 나면 npm install --save-dev babel-loader를 실행해서 설치해줍니다.

나머지는 공식 문서에 나온 것을 참고하시면 됩니다. :slight_smile:


(Jeff Kang) #2

어이구 문서대로하면 제대로 안되겠군요.


(이종은(Jong Lee)) #3

설치 방법 말고 babel-loader와 port 번호 관련해서는 PR이 있었네요. storybook을 잘 써보려고 합니다. storybook/react-native 관련해서 소스 코드도 찬찬히 뜯어보면서 개선에 참여해봐야겠네요.