Appcelerator에서 "certificate has expired"로 뜨면서 로그인이 안되네요.


#1

안녕하세요,

Appcelerator에서 "certificate has expired"로 뜨면서 로그인이 안되네요.

18

CLI에서도 마찬가지이고, Appcelerator Studio를 삭제하고 재설치를 해도 마찬가지입니다.

로그인 트러블슈팅 페이지에서 자바 인증서를 갱신하는 방법이 있어서 실행해봤는데
/System/Library/Java/Support/CoreDeploy.bundle/Contents 디렉토리 아래에 Home/lib/security/cacerts 디렉토리가 없어서 keytool 명령이 정상적으로 실행되지 않습니다.

https://docs.appcelerator.com/platform/latest/#!/guide/Errors_Logging_In_to_Studio

혹시 해결 방법을 아시는 분 계시는지요?


#2

트러블슈팅 페이지에 있는대로
curl -F “username=XXXX” -F “password=YYYY” https://dashboard.appcelerator.com/api/v1/auth/login
이렇게 로그인 테스트를 해보면 로그인 성공으로 나오는데, 정작 CLI나 스튜디오에서는 로그인하면 "certificate has expired"가 나옵니다.


#3

구글에 검색해 보면 스튜디오와 SDK를 업데이트한 후에 정상적으로 동작한다는 글이 있는데
CLI에서 스튜디오와 SDK를 업데이트하는 커맨드가 어떻게 되는지 아시면 좀 알려주세요.


#4

다행히도 간헐적으로 로그인이 되네요.
업데이트를 실행하면 에러가 나구요.
로그인 서버 쪽에 무슨 문제가 있는 것 같기도 합니다.

혹시 CLI에서 스튜디오와 SDK를 업데이트하는 커맨드가 어떻게 되는지 아시면 좀 알려주세요.


(이종은(Jong Lee)) #5

cli로 스튜디오는 업데이트는 안될 거에요.
SDK는 appc ti sdk install로 업데이트 할 수 있습니다.


#6

감사합니다.
지금은 스튜디오에서 업데이트가 동작하네요. (업데이트 할 내용은 없었습니다.)
Appcelerator 서버 쪽에 문제가 있었던 것 같습니다.


(InGrowth) #7

appc cli와 atom titanium ide 사용하고 있어서 스튜디오는 안켜본지 아주 오래 되었어요.


#8

저도 다른 용도로는 atom을 사용 중입니다. ^^